Liberty Mutual Bind and Pay outage
Incident Report for Briza.com
Resolved
This incident is now resolved.
Posted Oct 15, 2024 - 16:48 UTC
Monitoring
Liberty Mutual is experiencing issues in the Production environment - Bind and Pay is unavailable in the meantime, quoting is functional.
Posted Oct 10, 2024 - 21:07 UTC
This incident affected: API Production Environment (Binding).