Hiscox Proposal Documents Unavailable
Incident Report for Briza.com
Resolved
A fix for this incident was deployed at 1:55 PM
Posted Aug 22, 2023 - 20:42 UTC
Investigating
There’s an issue with retrieving Hiscox Quote Proposal documents. We have the root cause identified and we are continuing to work with the Hiscox IT team toward a resolution for this issue.
Posted Aug 22, 2023 - 15:26 UTC
This incident affected: API Sandbox Environment (Quotes) and API Production Environment (Quotes).