Amtrust quoting issues
Incident Report for Briza.com
Resolved
This incident has been resolved.
Posted Sep 06, 2024 - 22:08 UTC
Investigating
We are currently investigating issues with Amtrust quotes in our Production and Sandbox environments.
Posted Sep 06, 2024 - 19:28 UTC
This incident affected: API Sandbox Environment (Quotes) and API Production Environment (Quotes).