Hiscox quote documents unavailbale
Incident Report for Briza.com
Resolved
This incident has been resolved.
Posted Aug 24, 2023 - 22:15 UTC
Identified
Theres an issue retrieving Hiscox quote documents in Production due to SSL issues
Posted Aug 24, 2023 - 18:51 UTC
This incident affected: API Production Environment (Quotes).