Notice: Employers QA Environment Outage

Incident Report for Briza

Resolved

This incident has been resolved.
Posted Jul 25, 2026 - 11:53 UTC

Monitoring

Employers has informed us there will be an outage in their QA environment to perform database and system maintenance on Wednesday, 2026-07-22 lasting until Friday, 2026-07-24
Posted Jul 22, 2026 - 12:51 UTC