Hiscox Sandbox Failures

Incident Report for Briza.com

Resolved

Hiscox confirmed they have resolved the issues on their end.
Posted Jul 02, 2025 - 17:40 UTC

Update

We are still observing issues with quoting Hiscox in Sandbox. We're seeing different errors than before and have informed Hiscox of this.
Posted Jul 02, 2025 - 13:18 UTC

Monitoring

There are issues with quoting Hiscox in Sandbox. We've reached out to the Hiscox team and are monitoring the issue.
Posted Jul 01, 2025 - 16:00 UTC
This incident affected: API Sandbox Environment (Quotes).